Kanger ProTank - Battery Power Problems

Discussion in 'Cartos / Clearos / Atomizers' started by tref651, May 30, 2013.

  1. tref651

    tref651 New Member Member

    Joined:
    Dec 27, 2012
    Messages:
    22
    Location:
    Ontario
    Yup, just like the last thread regarding Kanger hardware. I'm now getting the same issues with the ProTanks, but with no possible answer in sight. I attempted to Google search anyone else on the face of this planet who is having this same problem, alas my efforts were in vain... :(

    Here's the thingy: I think it relates to using 2 different types of batteries: My eGo-C Twist battery - which it mostly works fine with, and then there's my eGo-V2. 90% of the time, when I'm using a clearo (or glasso?) on one type of battery, it won't work on the other type. I've tried adjusting the head by loosening or tightening, tried cleaning it out, all that jazz but to no avail.

    The frustrating part of all of this is that it seems no-one else has this problem. My batteries are reasonably clean, I've done the aforementioned clean-up methods necessary for the clearo itself... Most of the time, I've ended up having to use a new coil head and just hoping it works with the eGo V2.

    I'm lost!! :thumbsdown:
     
  2. saintjames

    saintjames Member Member

    Joined:
    Oct 22, 2012
    Messages:
    98
    Did you try raising the center pin on both batteries?

     
    MasterVapes likes this.
  3. tref651

    tref651 New Member Member

    Joined:
    Dec 27, 2012
    Messages:
    22
    Location:
    Ontario
    ...You, good sir, are my hero!!! Thank you for bringing this video to my attention!!! :):D \m/
     
  4. larry

    larry Guest

    wow... nice video.
    compare with PT, PT2, i'd like to chose the Davide Glassomizer
    can't wait to upgrade it to the XL tube :)
     

Share This Page